composer-php

Reference – Composer error "Your PHP version does not satisfy requirements" after upgrading PHP

After updating PHP from 7.4 to 8.0, I ran composer update on my existing project, and got an error like this:

  • acme/some-package[1.0.0, …, 1.4.0] requires php ^5.6.4 || ^7.0 -> your php version (8.0.3) does not satisfy that requirement.

What does this mean, and how do I fix it?

(This is a reference answer intended to cover a frequently encountered issue. The scenario is just an example. See also: “How to explain Composer’s error log?“)