libpcap installed on macOS but not supported

I ran a python code on IDE PyCharm with Python 3.9 in a MacOS 11.4(Big Sur) and I had installed the latest libpcap with homebrew and on venv via IDE.

But I got this error messages:

WARNING: No IPv4 address found on en5 !
WARNING: No IPv4 address found on bridge0 !
WARNING: more No IPv4 address found on ap1 !
Traceback (most recent call last):
File "/Users/bla/PycharmProjects/projet/main.py", line 7, in import libpcap
File "/Users/bla/.virtualenvs/projet/lib/python3.9/site-packages/libpcap/init.py", line 7, in from ._pcap import * ; del _pcap # noqa
File "/Users/bla/.virtualenvs/projet/lib/python3.9/site-packages/libpcap/_pcap.py", line 70, in from ._platform import is_windows, is_linux, defined
File "/Users/bla/.virtualenvs/projet/lib/python3.9/site-packages/libpcap/_platform/init.py", line 35, in from ._osx import DLL_PATH, DLL, dlclose, CFUNC
File "/Users/bla/.virtualenvs/projet/lib/python3.9/site-packages/libpcap/_platform/_osx/init.py", line 16, in
raise NotImplementedError("This OS is not supported yet!")
NotImplementedError: This OS is not supported yet!

Can someone help me, which action I need to undertake? Thanks



Read more here: https://stackoverflow.com/questions/68465462/libpcap-installed-on-macos-but-not-supported

Content Attribution

This content was originally published by monyet tenyom at Recent Questions - Stack Overflow, and is syndicated here via their RSS feed. You can read the original post over there.

%d bloggers like this: