Question about installing packages on Python 2.7

I am new to python and I am really confused about lot of things. I am developing my project mainly in PHP but as my host is unable to provide me access to v8js I have to use python to accomplish my tasks.

What I don't understand is: On my server is running python 2.7, and If I use pip to install latest version of some package, will it install version that will work with python 2.7 or it will install it even if it is meant to run only in python 3?

I am trying to install and use https://pypi.org/project/cfscrape/ but I can't force it to work, but when try it on Repl.it it is working without any problem.

So I guess that something is not right on my server but don't know what, as I just used pip install cfscrape and it intalled that package.



Read more here: https://stackoverflow.com/questions/64402379/question-about-installing-packages-on-python-2-7

Content Attribution

This content was originally published by SnowMan at Recent Questions - Stack Overflow, and is syndicated here via their RSS feed. You can read the original post over there.

%d bloggers like this: